You are either not logged in or not registered with our community. Click here to register.
 
December 04, 2016, 06:19:58 AM

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Click here if you are having problems.
Default Wide Screen Beige Lilac Rainbow Black & Blue October Send us your theme!

Hark!  The Herald!
Holiday Issue 2016

Wiki Blogs Dicebot

Author Topic: Windows 10 & NVIDIA GEForce Graphics Card  (Read 332 times)

0 Members and 1 Guest are viewing this topic.

Offline GypsyRoseTopic starter

Windows 10 & NVIDIA GEForce Graphics Card
« on: June 08, 2016, 09:00:16 AM »
Yesterday, I gave in and installed the Windows 10 update on my Lenovo laptop.  I tried the update when it first came out, and then rolled back to 8.1 after having some issues.  I figured that since it'd been long enough for most of the bugs to get worked out, and Windows 10 runs fine on my hubby's laptop and our desktops that I would try it again.

The install worked seamlessly this time.

The problem is that now Diablo III crashes the computer as soon as I try to start the game, with "video_tdr_failure nvlddmkm.syse"  It lets me open Diablo, log in, and I can change the settings, even play the video bits with no problem, but as soon as I have a character selected and start the game, *boom*  Blue screen with the video failure message.

I've tried disabling the Intel Graphics Driver.
I've tried updating the NVIDIA GEForce 750M driver, both using the Windows 10 update, and from the NVIDIA site itself.
I've tried uninstalling the GEForce Experience program, and just leaving the driver software.
I've tried uninstalling the NVIDIA graphics driver, and choosing a clean install when reinstalling.
I've tried uninstalling & reinstalling Diablo III.

After the last, I now get an error saying Diablo cannot initialize 3D3 rather than the crash.

Other programs seem to work fine, though Diablo III is the only graphics intensive game I've tried running.

Doing Google searches tells me that this has been a pretty common problem.    There seems to be a gazillion fixes for similar but not quite the same problem -- most of which led to the above steps.

Thought I'd post here to see if anyone else might have had this problem, and/or could suggest a fix I haven't tried.

Offline AmberStarfire

  • Rogue Starlight ~ Fantasy Novelist ~ This Is Who We Are ~ Scully to his Mulder
  • Dame
  • Carnite
  • *
  • Join Date: Aug 2008
  • Location: Somewhere that makes me smile
  • Gender: Female
  • ❤ Snuggler of the Wyld and Hairy ❤
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: Windows 10 & NVIDIA GEForce Graphics Card
« Reply #1 on: June 08, 2016, 09:24:36 AM »
I've noticed there are some differences in how Windows 10 seems to handle memory. It doesn't seem to manage games running alongside other programs as well as prior versions. If you have other software open at the same time, you could try closing out of it. Also try closing a computer process called SuperFetch because it consumes a lot of PC resources at times and if you're running out of memory, it may be a reason.

Something you may not have heard about Lenovo is that they got sprung a while ago for putting a rootkit and advertising software called Superfish on to a lot of their newer computers.

It may not be a problem, but I would start with that:
http://www.pcworld.com/article/2886278/how-to-remove-the-dangerous-superfish-adware-presintalled-on-lenovo-pcs.html

As for the game itself, you might be able to run it under Windows 7 or 8 mode. If you right click on the icon, there's a troubleshoot compatibility link in Windows 10. I don't know if it will help but you could try it.

You might find a more up to date driver for your NVIDIA card on their web site, if you didn't approach it that way.

Offline Drake Valentine

  • Architect of Worlds
  • Knight
  • Enchanter
  • *
  • Join Date: Jun 2009
  • Location: In the Deepest Depthes of Your Twisted Mind
  • Gender: Male
  • Making Your Darkest of Fantasies a Reality
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 0
Re: Windows 10 & NVIDIA GEForce Graphics Card
« Reply #2 on: June 08, 2016, 09:29:01 AM »
I had similar issue with this years and years ago when D3 came out, I don't recall the exact steps cause when I played at that time there was some video problems/broken screens and whatnot. I do believe I uninstalled the game, then updated the driver to current status, then reinstalled D3 and also ran D3 in admin mode afterwards and it worked fine then.

Other people in forums from what I browsed had said Scan/Repair for D3(in the options BNet tab thing for the game) had fixed similar crashing issues for them. Maybe it will work, dunno. I have no clue where my disk is to even attempt troubleshooting for it.

Offline AmberStarfire

  • Rogue Starlight ~ Fantasy Novelist ~ This Is Who We Are ~ Scully to his Mulder
  • Dame
  • Carnite
  • *
  • Join Date: Aug 2008
  • Location: Somewhere that makes me smile
  • Gender: Female
  • ❤ Snuggler of the Wyld and Hairy ❤
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: Windows 10 & NVIDIA GEForce Graphics Card
« Reply #3 on: June 08, 2016, 09:31:31 AM »
What we used to do with games was say try running it at the lowest settings, and if it works, increase it from there and see how it goes. Of course you might need to get it running in order to try it on the bare minimum.