You are either not logged in or not registered with our community. Click here to register.
 
December 03, 2016, 09:37:50 AM

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Click here if you are having problems.
Default Wide Screen Beige Lilac Rainbow Black & Blue October Send us your theme!

Hark!  The Herald!
Holiday Issue 2016

Wiki Blogs Dicebot

Author Topic: Image link failing to work  (Read 372 times)

0 Members and 1 Guest are viewing this topic.

Offline HaibaneTopic starter

Image link failing to work
« on: August 18, 2015, 02:39:31 PM »
Hi everyone. I'm currently suffering a weird link/URL failure from links sent to me by another E member.

Here is the link:

WARNING - NSFW!!!

https://41.media.tumblr.com/ff2c6242be900b7c3755fc8c879d129d/tumblr_msilu6yBu11senxy1o1_540.png

When I click the link I get this:



And as you can see from the address bar, the address has been changed to:

https://gs1.wac.edgecastcdn.net/8019B6/data.tumblr.com/ff2c6242be900b7c3755fc8c879d129d/tumblr_msilu6yBu11senxy1o1_540.png

I do not know why my browser (Firefox) is redirecting the link via "gs1.wac.edgecastcdn.net/8019B6/" as the original E member just doesn't see that part.

Can anyone help and tell me why its doing this? Thanks.
« Last Edit: August 20, 2015, 08:45:41 AM by Haibane »

Offline consortium11

Re: Image link failing to work
« Reply #1 on: August 18, 2015, 03:52:14 PM »
Image is NSFW.

Can't offer a huge amount of help here; I'm using Firefox and when I click the link it takes me straight to the picture rather than redirecting. I believe that EdgeCast is the CDN (content delivery network) for Tumblr (i.e. images stored on Tumblr are actually stored by EdgeCast) so what appears to have happened is that for whatever reason your browser tries to pull the image directly from EdgeCast (which it doesn't have access to) rather than through Tumblr itself... although unfortunately I don't know why that would be.

Offline HaibaneTopic starter

Re: Image link failing to work
« Reply #2 on: August 20, 2015, 04:52:11 AM »
Sorry about the NSFW image, I honestly had no idea what it was. I have removed it.

Thanks for the help. After further testing it seems to be an error in my browser specific only to tumblr. Its very weird. I now have to work out how to fix it. I wonder if it could be in the cache. It doesn't seem like a cache problem though since it fails with multiple linked files on tumblr.

Offline consortium11

Re: Image link failing to work
« Reply #3 on: August 20, 2015, 07:47:56 AM »
I don't think there's an issue with NSFW images if they're clearly tagged; it may be worth putting the link back in so others can see what the link is meant to show.

I'm not technical or familiar with tumblr/the coding for it enough to know if these offer a solution but these two links seem to be about people discussing the same issue and may offer a solution: one and two. Are you using the HTTPS Everywhere extension for your browser (or a similar one)? It's been suggested that it may be the cause and I believe there's an update out there that fixes it.

Offline HaibaneTopic starter

Re: Image link failing to work
« Reply #4 on: August 20, 2015, 08:38:51 AM »
I thought that NSFW images were not allowed in the public section of the forums? Perhaps I misunderstood that.

Anyway, I put the link back.

I am using HTTPS everywhere and have disabled it for Tumblr.

I checked those two sources of info Consortium and for now have disabled HTTPS Everywhere for Tumblr. That works. I see the images again.

Thank you so much for your kind help. I very much appreciate it! *hugs*
« Last Edit: August 20, 2015, 08:47:08 AM by Haibane »

Offline consortium11

Re: Image link failing to work
« Reply #5 on: August 20, 2015, 10:36:30 AM »
Quoting from the Rules post:

Quote
(With regard to NSFW things in the public areas) Linking to adult material is permitted if declared as adult / not safe for work (nsfw).

Anyway, glad it all got sorted out and that I could be of help  :-).