You are either not logged in or not registered with our community. Click here to register.
October 22, 2016, 08:20:40 PM

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Click here if you are having problems.
Default Wide Screen Beige Lilac Rainbow Black & Blue October Send us your theme!

Wiki Blogs Dicebot

Author Topic: Am I Human?  (Read 395 times)

0 Members and 1 Guest are viewing this topic.

Online SerephinoTopic starter

Am I Human?
« on: May 07, 2013, 04:11:51 PM »
I just tried to create a Steam account.  I filled everything out.  My user name and password and everything was fine.  The one problem was one of those 'are you human' things at the bottom where you have to type what's in the box.  Instead of creating the account for me the box just refreshed every time I clicked create account.  I've had problems with this before when I tried to recover the password to my Twitter account.  I would type everything in perfectly, and the page would just refresh with a new box thing.  I was using Firefox, but switched to IE and it did the same thing.

Offline Vekseid

Re: Am I Human?
« Reply #1 on: May 07, 2013, 05:32:42 PM »
This usually happens when you block cookies, or have some other 'privacy' features enabled.

Online SerephinoTopic starter

Re: Am I Human?
« Reply #2 on: May 07, 2013, 07:58:38 PM »
I don't have cookies blocked, I don't think.  How do I look at my privacy settings?

Offline Vekseid

Re: Am I Human?
« Reply #3 on: May 07, 2013, 08:31:17 PM »
You can try clearing your cookies and cache to see if that helps. Purchased firewalls like Norton and McAfee can also cause issues. That's the only thing I can think of that could be cross-browser.

Offline Geraint

  • Propigator of Plot Bunnies, RomanceCrack Dealer and Sireneous Wayword Muse Also Accused Plot Demon Breeder of Plotweilers ... Avatar by RampantDesires
  • Knight
  • Enchanter
  • *
  • Join Date: Mar 2011
  • Location: Someplace Historical, Hysterical, or Fantastic
  • Gender: Male
  • "There's no rush...but I can't wait."
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 0
Re: Am I Human?
« Reply #4 on: May 07, 2013, 11:04:10 PM »
I have occasionally noticed similar behavior by a web page authentication mechanisms when I have my display set to show things at type and image size set at above 100%.  It almost always happens if the screen is set at 150% of normal image size because it distorts the size of display and reply boxes on many sites.  And it sometimes does if it is set to 125%, at least in my experience.  The text and image size magnification should display if you click on Display in the Windows 7 Control Panel.

That might not be your problem, but it couldn't hurt to look.

Online SerephinoTopic starter

Re: Am I Human?
« Reply #5 on: May 07, 2013, 11:32:40 PM »
It's set to 100%.  I cleaned out my cookies, so we'll see if that helps.  I don't have any purchased firewalls.  I just have what comes with Windows and my antivirus (Avira and Malwarebytes).  It's only happened so far on Twitter, and now Steam.

Offline Moraline

Re: Am I Human?
« Reply #6 on: May 08, 2013, 11:14:09 AM »
Check your email (and spam folder) for a confirmation email. 

I had this same thing happen to me recently and it turned out something was weird with their form so it never looked like it got completed. However, I still got my confirmation letter and I was able to log into my newly created account.