Trouble viewing images linked from Twitter

Started by MrAlanNH, June 09, 2020, 12:03:20 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

MrAlanNH

Hi there all,
When viewing posts that have images that link from Twitter (pbs.twiimg.com) and ONLY from Twitter as far as I can tell, I only see a blank where the image is supposed to be.

For reference I present an example taken from a post by Sain in his Finder/Seeker picture thread.


Quote from: Sain on June 06, 2020, 07:38:08 AM






I've been having this trouble for quite a while but just now took the time to try and isolate the reason.

I normally use Firefox (77.0.1) in Privacy mode using SSeith's Elliquiy Improver script for TamperMonkey on a Windows 10 machine.

At first, I thought it might have something to do with the Elliquiy Improver script, but even if I disable it (and reload the site) I still can't see the images in posts.

I switched to MS Edge and in both normal and privacy mode (no script) I could view the images in posts.

Next I tried Firefox again, normal mode (script enabled and disabled) and privacy mode (script enabled and disabled).
No matter the script status, I could view images in posts in normal mode and could not in privacy mode.

So, it appears to be something to do with Firefox in privacy mode. 
However, if I directly enter the link for the image into a new tab (still in privacy mode) the image shows up with no problem.
So, it seems (to me) that it is a combination of Firefox Privacy mode and the Elliquiy site that causes a problem viewing these Twitter images from within an IMG tag.


Does anyone have any suggestions?
I know I could simply access the site from normal mode, but I'd prefer to continue accessing while utilizing privacy mode.







Tolvo

So I use firefox on Windows 10, and I can see the image. To help test I tried to view this post in private mode, the image doesn't appear. So it seems you hit the nail on the head.

Nowherewoman

A lot of outlinks run into trouble. Best thing to do, if you're set on using Private mode, is to rehost it to the WIKI here, or to  a hidden Pinterest.
My eyes are a window to the storm that's getting close.

more me here now!  (O/Os, ideas and junk): https://elliquiy.com/forums/index.php?topic=215830.0

and mea culpas  (A/As): https://elliquiy.com/forums/index.php?topic=221151.0

MrAlanNH

Quote from: Nowherewoman on June 09, 2020, 02:12:02 PM
A lot of outlinks run into trouble. Best thing to do, if you're set on using Private mode, is to rehost it to the WIKI here, or to  a hidden Pinterest.

The pics I'm having trouble viewing are ones that other folks post that .
Almost every pic I post are from Imgur or Pintrest.  So, as far as I know, others don't having trouble seeing the stuff I'm posting.

Amaris

I found this solution maybe it will help?



Here is the link if you can't view that image.


MrAlanNH

Thanks Amaris!
I'll look into it when I get a chance.  I'm just about to go out for dinner, so I'll see if it helps when I get back.

MrAlanNH

OK, the directions from Firefox 42 don't quite match up to the way the latest version is set up but by poking around in the Options area (the three horizontal bars in the upper right corner) in the Privacy & Security section I found if I went from the Standard setting of the Enhanced Tracking Protection to the Custom setting and unchecked Tracking Content, now I can see the images linked from Twitter in posts.  Sorry for the slightly blurry screenshot.

Now I have to decide if I prefer keeping the protection from Tracking Content on, or to see these Twitter linked images automatically.


greenknight

Necro-time....

I've had the same problem forever, thanks for explaining why. pbs.twimg.com is identified as social media tracker. Does it work if I don't have an associated account at all?
When you bang your head against the wall, you don't get the answer, you get a headache.

O/O: https://elliquiy.com/forums/onsoffs.php?u=46150