You are either not logged in or not registered with our community. Click here to register.
 
December 15, 2017, 04:28:35 AM

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Click here if you are having problems.
Default Wide Screen Beige Lilac Rainbow Black & Blue October Send us your theme!

Wiki Blogs Dicebot

Author Topic: Website Timing Out Error  (Read 503 times)

0 Members and 1 Guest are viewing this topic.

Offline TheGlyphstoneTopic starter

Website Timing Out Error
« on: April 08, 2017, 12:51:31 PM »
So a single specific website - us.blizzard.com - won't load at all for me. It just hangs up and times out.

I've confirmed via downforeveryoneorjustme.com that the issue is on my end.

I've tried it in multiple browsers, both IE and Firefox, so it's not a browser issue.

I've tried it from two different computers in the house, so it's not a computer-specific issue.

This means it is probably a router problem, but I don't know what the next step is to isolate and/or fix it.

Offline Nadir

  • Dim Hon || The Horrible, Lovely Thing || The Sorcerer's Familiar || Not This || Desire of the Endless || More Dark In Me Than Bones || St. Fucking || Ignis et Crepitus
  • Oracle
  • Carnite
  • *
  • Join Date: Dec 2008
  • Location: ne invoces expellere non possis || The aforementioned darkness
  • It'll look better with blood on it || [Glass Him]
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 19
Re: Website Timing Out Error
« Reply #1 on: April 08, 2017, 01:50:34 PM »
I'd not jump to that conclusion so fast, the site timed out for me too

Online Theta Sigma

Re: Website Timing Out Error
« Reply #2 on: April 08, 2017, 02:10:56 PM »
The Blizzard servers appear hideous at the moment. Whilst it loaded for me, the EU site is always slow, and the in-game WoW servers are shocking at the moment.

Offline Sprikut

Re: Website Timing Out Error
« Reply #3 on: May 09, 2017, 06:29:43 PM »
You can try running a trace route to the Blizzard servers to see where along the line the request times out. Or you can remote log into your Router and check for a block. But its unlikely thats the issue.