You are either not logged in or not registered with our community. Click here to register.
 
December 06, 2016, 12:20:55 AM

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Click here if you are having problems.
Default Wide Screen Beige Lilac Rainbow Black & Blue October Send us your theme!

Hark!  The Herald!
Holiday Issue 2016

Wiki Blogs Dicebot

Author Topic: El Text Editor problems  (Read 570 times)

0 Members and 1 Guest are viewing this topic.

Offline NowherewomanTopic starter

  • Arbitrarily Arousable, Selectively Insatiable
  • Dame
  • Addict
  • *
  • Join Date: Aug 2014
  • Location: In the depths of an orc fortress
  • Gender: Female
  • These ears are made for nibbling.
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
El Text Editor problems
« on: December 29, 2015, 07:39:08 PM »
OK...for a long time, I just was quiet and dealt with this, because I seemed to be the only person experiencing these issues. But they're happening on 2 different machines, the only commonality being the OS (Win10) and the browser- Chrome- so I am BEGGING for any ideas.

Simply put, the editor here very frequently, under certain circumstances, inserts or removes formatting commands on its own.  The most repeatable issues are:

-cut+paste or Copy+paste almost always inserts formatting to set the font size to infinitesimal, and often removes a great deal of other formatting, as well. You can imagine what a PITA this is when folks use code blocks for character sheets and the like (as they so often do). I've had some success in heading this off by hitting the 'clear formatting' button before pasting- but not always.


-deleting across a line break using BKSPC almost always inserts a font size change at the point the line 'wraps back'.


-going back and editing a post that uses the 'center' or 'padding=' commands will, 100% of the time, delete those format marks, untouched by human hands. If there is an image associated with the padding command, if usually vanishes, as well. (in case any of my friendly GMs have wondered why I don't pad my images in posts- that's why. Fixing a typo results in endless extra work if I do.)


Has anyone else run into any of these quirks? Or are there any ideas on what might be causing it? The first few times I just figured pilot error, but they are consistently reproducible, and have been for the whole time I've been here, even changing from WIN7 (on the home machine) and WIN8 (on my laptop) to WIN 10, and updating Chrome.

Offline NowherewomanTopic starter

  • Arbitrarily Arousable, Selectively Insatiable
  • Dame
  • Addict
  • *
  • Join Date: Aug 2014
  • Location: In the depths of an orc fortress
  • Gender: Female
  • These ears are made for nibbling.
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #1 on: December 31, 2015, 04:47:37 PM »
Bumping this because it just did it to me AGAIN. This time I did all my editing in an outside text editor, to avoid having to fix all the mistakes the resident editor inserts into copy and pasted text blocks. The result looked fine to ME, but was apparently illegible to someone I PMed it to.


Now, I find it quite likely that in this one case the interpolated formatting problems were the work of the outside editor- but then WTF didn't I see them in the copy of the document I mailed to myself?


It's getting to the point that I don't care to try to get involved in any game with a formal character sheet, because I know much heartbreak and cursing will result.


Anyone?  Anyone at all?




Online Al Terego

Re: El Text Editor problems
« Reply #2 on: January 03, 2016, 04:13:42 PM »
Go to your profile settings and look under "Look and Layout" at the "Show WYSIWYG editor on post page by default" setting.

If you have it checked, the formatting may change as you describe.  I have noticed it on many sites that use similar editors.

I do not use the setting myself, preferring to see (and even type) raw bbcode.  That way I know exactly what formatting is used, and the "preview" feature shows me what it would look like.


Offline AmberStarfire

  • Rogue Starlight ~ Fantasy Novelist ~ This Is Who We Are ~ Scully to his Mulder
  • Dame
  • Carnite
  • *
  • Join Date: Aug 2008
  • Location: Somewhere that makes me smile
  • Gender: Female
  • ❤ Snuggler of the Wyld and Hairy ❤
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #3 on: January 03, 2016, 05:03:37 PM »
I haven't experienced those problems. If it's not linked to a specific browser, then it stands to reason that it probably is your settings and Al Terego's suggestion seems quite possible.

What I find odd is on Elliquiy, when you go to write a post there already is a WYSIWYG editor. It's that section that lets you format your post, yet I know I don't have the box ticked on my settings for it. It may be that there's a conflict between the one in under 'Look and Layout' and the one that's ordinarily set up to work with Elliquiy.






Offline NowherewomanTopic starter

  • Arbitrarily Arousable, Selectively Insatiable
  • Dame
  • Addict
  • *
  • Join Date: Aug 2014
  • Location: In the depths of an orc fortress
  • Gender: Female
  • These ears are made for nibbling.
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #4 on: January 03, 2016, 05:05:30 PM »
Thanks, Al!  Someone else had suggested that, as well, but when I tried to turn it off even odder things happened- like hitting 'reply' and having it auto-insert quotes from earlier in the thread I was replying to!  I'm not sure if it's my version of Chrome, some sort of OS issue, or what, but for me, at least, the editor here seems to be cursed. I just need to step through it as if I were walking through a minefield.

*EDIT*  OK, the latter issue seems perhaps to be linked to Ssieth's draft code, but I haven't confirmed that yet.

And yeah, Amber- not many folks seem to have the slightest idea what I'm talking about. And yet it is almost 100% reproducible at my end. Very annoying.
« Last Edit: January 03, 2016, 05:07:28 PM by Nowherewoman »

Offline NowherewomanTopic starter

  • Arbitrarily Arousable, Selectively Insatiable
  • Dame
  • Addict
  • *
  • Join Date: Aug 2014
  • Location: In the depths of an orc fortress
  • Gender: Female
  • These ears are made for nibbling.
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #5 on: January 03, 2016, 05:08:51 PM »
*second edit*

OK, clearing the Chrome cache and reloading El got rid of the spurious quote insert issues w/WYSIWYG turned off. I'll try it this way for a while, and see if stuff improves.  Thanks, folks!

Offline AmberStarfire

  • Rogue Starlight ~ Fantasy Novelist ~ This Is Who We Are ~ Scully to his Mulder
  • Dame
  • Carnite
  • *
  • Join Date: Aug 2008
  • Location: Somewhere that makes me smile
  • Gender: Female
  • ❤ Snuggler of the Wyld and Hairy ❤
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #6 on: January 03, 2016, 05:09:53 PM »
If it's any help, that's how I have the settings for Look and Layout:

https://elliquiy.com/elluiki/images/6/6f/ElliqSettings.jpg

Though the box 'show most recent posts at the top' will reverse the posting order, so the new posts are at the top and older posts at the bottom.

Offline NowherewomanTopic starter

  • Arbitrarily Arousable, Selectively Insatiable
  • Dame
  • Addict
  • *
  • Join Date: Aug 2014
  • Location: In the depths of an orc fortress
  • Gender: Female
  • These ears are made for nibbling.
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #7 on: January 03, 2016, 05:15:42 PM »
Thanks, hun. It does not seem to have fixed the issue, btw. Cutting and pasting blocks of text still inserts font and size changes UNLESS I hit the 'change view' button first.  *sigh* Goddess bless sitcky noes. Just need to keep reminding myself.

Offline AmberStarfire

  • Rogue Starlight ~ Fantasy Novelist ~ This Is Who We Are ~ Scully to his Mulder
  • Dame
  • Carnite
  • *
  • Join Date: Aug 2008
  • Location: Somewhere that makes me smile
  • Gender: Female
  • ❤ Snuggler of the Wyld and Hairy ❤
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #8 on: January 03, 2016, 05:22:45 PM »
Thanks, hun. It does not seem to have fixed the issue, btw. Cutting and pasting blocks of text still inserts font and size changes UNLESS I hit the 'change view' button first.  *sigh* Goddess bless sitcky noes. Just need to keep reminding myself.

What's the change view button?

Online Al Terego

Re: El Text Editor problems
« Reply #9 on: January 03, 2016, 06:50:36 PM »
My settings are here

The change view should only be active if WYSIWYG mode is on.  Are you sure you hit the "Change profile" button to save your changes?

Offline NowherewomanTopic starter

  • Arbitrarily Arousable, Selectively Insatiable
  • Dame
  • Addict
  • *
  • Join Date: Aug 2014
  • Location: In the depths of an orc fortress
  • Gender: Female
  • These ears are made for nibbling.
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #10 on: January 03, 2016, 08:04:37 PM »
yup, and double-checked to be sure the radio button was cleared.  But the Change View button is still active (even after clearing the browser cache again- ran into that before with trying to change themes), and copy-paste still adds a bunch of crap unless I hit it before pasting.



And neither your nor Amber's setting are any different from mine, save for having originally had the editor checked, and setting new posts to appear at the top, for Amber.

Offline NowherewomanTopic starter

  • Arbitrarily Arousable, Selectively Insatiable
  • Dame
  • Addict
  • *
  • Join Date: Aug 2014
  • Location: In the depths of an orc fortress
  • Gender: Female
  • These ears are made for nibbling.
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #11 on: January 03, 2016, 08:14:54 PM »
After a bit of digging, I discovered one of my issues was actually reported back in 2012:

Not sure if this has been raised before, or even if I'm the only person having such issues. But for some reason when I'm making a post or writing a pm and try to make edits like add a sentence or paragraph, or take them away before posting/submitting, occasionally the font size changes on me to something like size=78% or something, so half my post winds up being smaller than the rest. That is, if it doesn't just throw the size tags into the post itself.


[size=78%]Here's an example of what happens....I didn't manually type the size tags. I didn't even mess with the font size drop down. All I did was type the first part of this paragraph, then go back and delete the empty line between it and the above paragraph (a common [/size]occurrence[size=78%] when proof reading/making final edits before posting)...the size difference persists, even when I hit enter to drop it back down to where it belongs....[/size]

[size=78%]And continues to effect all text I write afterwards. The only way to fix this is to turn off wysiwyg mode and manually delete the tags. Needless to say this is very annoying, and I have no idea what is causing it.[/size]

[size=78%]In case it matters, the browser I use is Chrome.[/size]

Online Al Terego

Re: El Text Editor problems
« Reply #12 on: January 03, 2016, 09:29:25 PM »
Hmmm... curiouser and curiouser.

Maybe the theme has something to do with it?

Offline NowherewomanTopic starter

  • Arbitrarily Arousable, Selectively Insatiable
  • Dame
  • Addict
  • *
  • Join Date: Aug 2014
  • Location: In the depths of an orc fortress
  • Gender: Female
  • These ears are made for nibbling.
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #13 on: January 04, 2016, 08:37:32 AM »
Possibly, though I'm on the default template again.

Annnd now it's started inserting text when I hit 'reply' again.  So I have come to the conclusion that either 1)There's something screwy with this build of Chrome 2)the BBS code that El is running on is really really bad; or 3)some combination of these in varying proportions.

It was heartening to see that I'm not completely nuts, and someone else had similar issues at one time, though :D

Offline AmberStarfire

  • Rogue Starlight ~ Fantasy Novelist ~ This Is Who We Are ~ Scully to his Mulder
  • Dame
  • Carnite
  • *
  • Join Date: Aug 2008
  • Location: Somewhere that makes me smile
  • Gender: Female
  • ❤ Snuggler of the Wyld and Hairy ❤
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #14 on: January 04, 2016, 08:46:44 AM »
Which button do you press when you reply?

And have you had the same trouble with the other themes?


Offline NowherewomanTopic starter

  • Arbitrarily Arousable, Selectively Insatiable
  • Dame
  • Addict
  • *
  • Join Date: Aug 2014
  • Location: In the depths of an orc fortress
  • Gender: Female
  • These ears are made for nibbling.
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #15 on: January 04, 2016, 08:51:10 AM »
Just 'reply'. It seems as if, somehow, some crap is being retained in a clipboard, but NOT the standard windows one, as that should be cleared on reboot. It's possible this particular issue has something to do with Ssie's extension scripts; I'll talk to her when I get a chance about it.

I haven't tried all the themes, but I have used 2 or 3. Same problem- though I have NOT tried changing them since I turned off the WYSIWYG button (in theory, at least, since it actually seems to do naught). Going to try that now.

Offline AmberStarfire

  • Rogue Starlight ~ Fantasy Novelist ~ This Is Who We Are ~ Scully to his Mulder
  • Dame
  • Carnite
  • *
  • Join Date: Aug 2008
  • Location: Somewhere that makes me smile
  • Gender: Female
  • ❤ Snuggler of the Wyld and Hairy ❤
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #16 on: January 04, 2016, 08:55:33 AM »
I'd say change the themes under Look and Layout, and choose Elliquiy 2 in the option list then whatever theme you want to try.

Did you try ctrl-f5 for a forced refresh? Sometimes changes are made to the themes and if you don't do ctrl-f5, it still loads the page with the old theme if your computer has it cached.
« Last Edit: January 04, 2016, 08:57:10 AM by AmberStarfire »

Offline NowherewomanTopic starter

  • Arbitrarily Arousable, Selectively Insatiable
  • Dame
  • Addict
  • *
  • Join Date: Aug 2014
  • Location: In the depths of an orc fortress
  • Gender: Female
  • These ears are made for nibbling.
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #17 on: January 04, 2016, 09:02:31 AM »
OK, got the theme to stick. But I've just discovered that even using 'modify' will actually REPLACE the existing text with whatever fragment it has somehow stored.  Since this actually makes editing even LESS functional- WYSIWYG is going back on.

I do appreciate the attempts to help, folks- it seems my Mighty Vortex of Weird has me in its clutches again!

Offline AmberStarfire

  • Rogue Starlight ~ Fantasy Novelist ~ This Is Who We Are ~ Scully to his Mulder
  • Dame
  • Carnite
  • *
  • Join Date: Aug 2008
  • Location: Somewhere that makes me smile
  • Gender: Female
  • ❤ Snuggler of the Wyld and Hairy ❤
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #18 on: January 04, 2016, 09:08:01 AM »
I noticed a few people had different fixes for the non-sticking theme problem (for most people resetting cookies and changing it under Look and Layout using Elliquiy 2 worked).

I noticed Rogue came up with this odd fix for the non-sticking theme problem:
https://elliquiy.com/forums/index.php?topic=232597.msg11443564#msg11443564

Another approach people have used is bookmarking the page with the theme you want (on the Elliquiy main page for instance), then when you want to load it, just click the bookmark. I tend to do that just because it's handy.

As for the text editor problem, maybe Vekseid would see something in your settings that we can't.

Offline NowherewomanTopic starter

  • Arbitrarily Arousable, Selectively Insatiable
  • Dame
  • Addict
  • *
  • Join Date: Aug 2014
  • Location: In the depths of an orc fortress
  • Gender: Female
  • These ears are made for nibbling.
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #19 on: January 04, 2016, 11:19:00 AM »
Couldn't hurt.  ATM, I am as follows:



Offline AmberStarfire

  • Rogue Starlight ~ Fantasy Novelist ~ This Is Who We Are ~ Scully to his Mulder
  • Dame
  • Carnite
  • *
  • Join Date: Aug 2008
  • Location: Somewhere that makes me smile
  • Gender: Female
  • ❤ Snuggler of the Wyld and Hairy ❤
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #20 on: January 04, 2016, 11:24:13 AM »
I made that theme so hopefully it isn't the reason.  ::)

I would untick the boxes for leaving words uncensored and return to topics after posting by default, just in case there's some unintended action from those and it's causing the problems. Those things should happen by default anyway unticked (at least, I think they do). Also disable the WYSIWYG box.

Apart from that I don't really know.

Online Al Terego

Re: El Text Editor problems
« Reply #21 on: January 04, 2016, 11:59:20 AM »
Do you have any extensions installed for chrome?

Another thing I can think of is disabling Autofill:
https://support.google.com/chrome/answer/142893?hl=en

Offline NowherewomanTopic starter

  • Arbitrarily Arousable, Selectively Insatiable
  • Dame
  • Addict
  • *
  • Join Date: Aug 2014
  • Location: In the depths of an orc fortress
  • Gender: Female
  • These ears are made for nibbling.
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #22 on: January 04, 2016, 12:00:15 PM »
I made that theme so hopefully it isn't the reason.  ::)

I would untick the boxes for leaving words uncensored and return to topics after posting by default, just in case there's some unintended action from those and it's causing the problems. Those things should happen by default anyway unticked (at least, I think they do). Also disable the WYSIWYG box.

Apart from that I don't really know.


As I said, if I disable teh WYSIWYG checkbox, I get even worse problems with posting. I haven't had a chance yet to tweak Ssieth's script settings, ot see if that's part of the issue, but that's on the to-do list for today or tomorrow.  I can certainly kill the others, see if that fixes anything.




Adblock.  Hadn't thought about the autofill thing- I find it useful when I shop online, but that's a good thought!
Do you have any extensions installed for chrome?

Another thing I can think of is disabling Autofill:
https://support.google.com/chrome/answer/142893?hl=en


Online Al Terego

Re: El Text Editor problems
« Reply #23 on: January 04, 2016, 12:01:50 PM »
I would untick the boxes for leaving words uncensored and return to topics after posting by default, just in case there's some unintended action from those and it's causing the problems. Those things should happen by default anyway unticked (at least, I think they do). Also disable the WYSIWYG box.

I have those boxes ticked on all the discussion boards that I post on, with no problems whatsoever.
Censoring words has no place on adult forums.

Offline NowherewomanTopic starter

  • Arbitrarily Arousable, Selectively Insatiable
  • Dame
  • Addict
  • *
  • Join Date: Aug 2014
  • Location: In the depths of an orc fortress
  • Gender: Female
  • These ears are made for nibbling.
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: El Text Editor problems
« Reply #24 on: January 04, 2016, 12:03:06 PM »
Turning off Autofill doesn't fix the problem with it inserting text using 'reply'. BUT- hitting the 'clear draft' button from Ssie's scripts and then reloading makes it go away. It does, in fact, seem to be an odd interaction with the script controlling drafts.  I'll see if I can kill that segment, and will talk to her about a bughunt later.