News:

Northern Town [L-H]
Congratulations SlowBurnGirl & Shengami for completing your RP!

Main Menu

I'm nod admin of my own device

Started by Azy, September 16, 2021, 06:12:15 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Azy

So I bought en external CD drive in the hopes of putting an old game on my laptop that has no cd drive.  I plug the device in the usb port, everything seems to be working fine.  I click on run the exe to install.  I get this popup.  This has been blocked by admin for your own protection.  Contact admin.  I am admin since it's my fucking laptop and no one else uses it, but okay.  So I google.  I shut off my antivirus.  That doesn't work.  I type a thing into a command prompt black screen thing.  Access denied.  I set account user control to not notify me to changes.  I am still being protected from my own fucking game.  I'm gonna go curl up in a corner and cry now, maybe after smashing the laptop to bits because apparently it's not mine and I have no say over what it will and will not install....

Nowherewoman

Silly question, but have you tired r-clicking and selecting 'run as Administrator'? That's assuming you're on WinDurrrz of some version.

You might also try doing a hard reboot with the drive plugged in beforehand, see if that resets permissions at all.
My eyes are a window to the storm that's getting close.

more me here now!  (O/Os, ideas and junk): https://elliquiy.com/forums/index.php?topic=215830.0

and mea culpas  (A/As): https://elliquiy.com/forums/index.php?topic=221151.0

Azy

That was suggested on the sites I looked up, but I can't find anything to R click on because in devices it's not showing up except as removable device.  Maybe that's the problem?  I am running Windows 10.  How would I do a hard reboot of an external drive?

Vekseid

On the executable itself. You right-click any executable, you can choose to 'run as administrator'.

Alternately, you can disable user account control, which is doing this in the first place. In the start menu, type 'uac', and open 'Change User Account Control Settings'. Drag it down to 'Never Notify'.

It's possible this may not be enough, you might have to change the group policy setting:

Search for 'Policy' in the search box and open 'Edit group policy.

Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options

Scroll down to to User Account Control: Run all administrators in Admin Approval Mode.

Double-click, choose Disabled and click OK.




Do make sure to re-enable these after you've installed your game.

Azy

Okay.  I tried user account control, but that didn't work.  I will try the other thing.  Thank you guys. 

Vekseid

There's manually editing the registry setting also, if group policy doesn't work, but that should be what is causing the popup.

Azy

I had a tech savvy friend play with it.  Apparently Windows 10 no longer allows auto run because of some viruses.  Getting to DOS and circumventing Windows did the trick.  However, my disk is too worn to install.   :'(

Vekseid

Is the top side scratched? What game is it?

Azy

The Sims 2 Double Deluxe.  It is pretty scratched up.  My old lady of a desktop was able to install it, but as it was explained to me by my ex newer and faster drives can have issues with scratches.  I used to have 2 copies.  Both had scratches bad enough to prevent a gaming laptop from being able to install, but the disks were scratched in different places, so what we ended up doing was when one had an issue we popped in the other.  I have no idea what happened to my second copy.  I probably left a lot of things behind when I ran away. 

Vekseid

Do not have that one : /

And yeah. Sometimes what you can do is burn a CD image to an .iso file, and use that. Some more advanced ripping software has ways to carefully control the CD reader.