You are either not logged in or not registered with our community. Click here to register.
 
December 05, 2016, 09:05:07 PM

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Click here if you are having problems.
Default Wide Screen Beige Lilac Rainbow Black & Blue October Send us your theme!

Hark!  The Herald!
Holiday Issue 2016

Wiki Blogs Dicebot

Author Topic: Forcing https?  (Read 5898 times)

0 Members and 1 Guest are viewing this topic.

Online Lorelei Adelaide

  • Dixieland Delight
  • Lady
  • Addict
  • *
  • Join Date: Nov 2012
  • Location: Let me show you how Country Feels. Resident Cowgirl.
  • Gender: Female
  • Dancing with the Fireflies
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 4
Re: Forcing https?
« Reply #125 on: August 23, 2013, 07:09:58 PM »
HTTPS works for me

Offline LordHarketh193

Re: Forcing https?
« Reply #126 on: August 23, 2013, 07:11:36 PM »
Works for me.

A bit slow though.
« Last Edit: August 23, 2013, 07:12:40 PM by LordHarketh193 »

Offline kylie

  • Bratty Princess of Twisty, Creeping Secrets. Frilly | Fussy | Framed | Dreamy | Glam | Risky | Sporty | Rapt | Tease | Ironic | Shadowed | Struggling | Whispery | Bespelled
  • Liege
  • Enchanter
  • *
  • Join Date: Apr 2005
  • Location: Somewhere in the future.
  • Darkly sweet femme for rich & insidious scenarios.
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: Forcing https?
« Reply #127 on: August 23, 2013, 07:44:18 PM »
     It works for me, tried Explorer and Firefox.

(Firefox seems much faster.  Don't usually use that so not sure if it is a general difference or specific to this.) 

And I'm on wifi in Central Asia at the moment, if that makes any difference to the roster  :-)

Offline Nessy

Re: Forcing https?
« Reply #128 on: August 23, 2013, 07:55:36 PM »
It works for me, but like someone else, now I can't get rid of the new message message.

Offline RainyHigh

Re: Forcing https?
« Reply #129 on: August 23, 2013, 08:22:36 PM »
Https works for me.

Offline Josietta

  • ♥ The Sweet Lil Heartbreaker of E ◦ Princessa ◦ BabyCakes ◦ | Minx | SisterKitten | ~ MC Wifey ~ ✨ Ely's Bestie Babe ✨ ♥ Jewel ♥ ֍ Babygirl ֍
  • Dame
  • Carnite
  • *
  • Join Date: Aug 2008
  • Location: ♥ HawkGirl -- GO SEAHAWKS!! ♥
  • Gender: Female
  • ~ His Kitten ~
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 0
Re: Forcing https?
« Reply #130 on: August 23, 2013, 08:26:59 PM »
It works for me, but like someone else, now I can't get rid of the new message message.

Try clearing your cookies and cache.   That helped me when I had that issue before.

Offline Mithlomwen

  • ~ E's resident kilt inspector ~ ~ Atropos ~
  • Goddess
  • Carnite
  • *
  • Join Date: Oct 2008
  • Location: Somewhere between the dark and the light...
  • Gender: Female
  • ~ Thunder only happens when it's raining.... ~
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 0
Re: Forcing https?
« Reply #131 on: August 23, 2013, 08:54:51 PM »
Both work for me. 

Online AmberStarfire

  • Rogue Starlight ~ Fantasy Novelist ~ This Is Who We Are ~ Scully to his Mulder
  • Dame
  • Carnite
  • *
  • Join Date: Aug 2008
  • Location: Somewhere that makes me smile
  • Gender: Female
  • ❤ Snuggler of the Wyld and Hairy ❤
  • My Role Play Preferences
  • View My Rolls
  • Referrals: 1
Re: Forcing https?
« Reply #132 on: August 23, 2013, 09:04:18 PM »
Https works fine for me, at least for the most part.

I noticed that some previously-embedded videos from Youtube are now only showing up as hyperlinks, and that's both on the https and http version of the site.

The site also switches back to regular http when I click on your link to come to this thread.

Offline DarkCassandra

Re: Forcing https?
« Reply #133 on: August 23, 2013, 09:13:45 PM »
Both seem to be working fine with me, and HTTPS is equally as fast (though I've used it most of the time anyway) for me.

Online stormwyrm

Re: Forcing https?
« Reply #134 on: August 23, 2013, 09:25:29 PM »
I actually made a ruleset on HTTPS Everywhere that essentially simulates the effect of the proposed change. So far, I find no oddities anywhere.

Offline Nessy

Re: Forcing https?
« Reply #135 on: August 23, 2013, 09:48:19 PM »
Try clearing your cookies and cache.   That helped me when I had that issue before.

Going back to the the http:// site was easier, and cleared it right up.

Offline The Infamous

Re: Forcing https?
« Reply #136 on: August 23, 2013, 10:07:50 PM »
Wonderful.

Offline Chris Brady

Re: Forcing https?
« Reply #137 on: August 23, 2013, 10:35:02 PM »
I'm all for HTTPS, as long as it's more secure.

As a Canadian National, I'm not comfortable with the potential spying by a foreign agency.  I know it happens and for the most part what we do here isn't very important, but...  I don't know, I just don't like it.  So HTTPS is OK for me.

Offline Starlequin

Re: Forcing https?
« Reply #138 on: August 23, 2013, 11:13:32 PM »
Both are working well for me so far.

Offline dragonsen

Re: Forcing https?
« Reply #139 on: August 23, 2013, 11:29:19 PM »
I actually made a ruleset on HTTPS Everywhere that essentially simulates the effect of the proposed change. So far, I find no oddities anywhere.

Could I get a copy of your ruleset for E until this change is implemented?

Online stormwyrm

Re: Forcing https?
« Reply #140 on: August 23, 2013, 11:53:04 PM »
For those of you who are interested in trying out the HTTPS Everywhere ruleset. Copy/paste this into Notepad and save it as Elliquiy.xml.

Code: [Select]
<ruleset name="Elliquiy">
  <target host="www.elliquiy.com" />
  <target host="elliquiy.com" />

  <rule from="^http://(www\.)?elliquiy\.com/" to="https://elliquiy.com/"/>
</ruleset>

Then, in Firefox, go to Help->Troubleshooting Information and under the Application Basics section, click on Open Containing Folder. There a window will appear and you should copy the Elliquiy.xml file inside the HTTPSEverywhereUserRules folder. Then restart your browser. These instructions of course are specific for Windows. Not sure how it's done on OS X or any other OS but it boils down to putting the ruleset in the folder where user rules are stored, and restarting the browser (or alternatively disabling and re-enabling HTTPS Everywhere).

Offline TheRedWind

Re: Forcing https?
« Reply #141 on: August 24, 2013, 12:02:02 AM »
Works for me.

Offline Marikir

Re: Forcing https?
« Reply #142 on: August 24, 2013, 12:18:47 AM »
Good on my end, I believe.

Offline Riveda

Re: Forcing https?
« Reply #143 on: August 24, 2013, 01:20:40 AM »
I've had an HTTPSEverywhere rule forcing https access site-wide ever since I joined E, and it works fine except for uploading files to the wiki. I have to turn it off and use http to get that to work.

Offline Achmed the Mad

Re: Forcing https?
« Reply #144 on: August 24, 2013, 01:25:07 AM »
Same here, except I use the option in NoScript (for Firefox) to force https.


Offline Naomi75

Re: Forcing https?
« Reply #145 on: August 24, 2013, 01:31:56 AM »
I suppose whatever works for you works for me! LOL Thanks for asking but I'm tech challenged so I defer to your judgment!

Offline Cthonig

Re: Forcing https?
« Reply #146 on: August 24, 2013, 01:56:22 AM »
Both work for me.

Offline realisticwordweaver

Re: Forcing https?
« Reply #147 on: August 24, 2013, 02:35:59 AM »
Search does not work for me either ways

Offline Indyo

Re: Forcing https?
« Reply #148 on: August 24, 2013, 02:36:05 AM »
Works fine here, Veks :)

Offline VekseidTopic starter

Re: Forcing https?
« Reply #149 on: August 24, 2013, 02:52:02 AM »
For those of you who are interested in trying out the HTTPS Everywhere ruleset. Copy/paste this into Notepad and save it as Elliquiy.xml.

Code: [Select]
<ruleset name="Elliquiy">
  <target host="www.elliquiy.com" />
  <target host="elliquiy.com" />

  <rule from="^http://(www\.)?elliquiy\.com/" to="https://elliquiy.com/"/>
</ruleset>

Then, in Firefox, go to Help->Troubleshooting Information and under the Application Basics section, click on Open Containing Folder. There a window will appear and you should copy the Elliquiy.xml file inside the HTTPSEverywhereUserRules folder. Then restart your browser. These instructions of course are specific for Windows. Not sure how it's done on OS X or any other OS but it boils down to putting the ruleset in the folder where user rules are stored, and restarting the browser (or alternatively disabling and re-enabling HTTPS Everywhere).

Could you add securecookie to that and check to make sure it works, please?

Code: [Select]
<ruleset name="Elliquiy">
  <target host="www.elliquiy.com" />
  <target host="elliquiy.com" />

  <rule from="^http://(www\.)?elliquiy\.com/" to="https://elliquiy.com/"/>
  <securecookie host="^(\.)?elliquiy\.com$" name="(ElliSMFCookie11|PHPSESSID)" />
</ruleset>